PathfinderWiki
Log in

Difference between revisions of "Forum:New forums have "Forum" twice in article names"

From PathfinderWiki
(Created page with "<div class="forumheader">'''Forums:''' Workshop > {{PAGENAME}}</div>{{PAGENAME}}<br /> <!-- Start your edit below this line. Y...")
 
(Propose fix)
 
Line 7: Line 7:
 
| I don't know when this problem started, but we now have to manually delete or move articles in the Forum namespace, as the automatic thread creation tool makes the titles "Forum:Forum:Thread title." Any way we can fix this behavior in the new article creation tool?
 
| I don't know when this problem started, but we now have to manually delete or move articles in the Forum namespace, as the automatic thread creation tool makes the titles "Forum:Forum:Thread title." Any way we can fix this behavior in the new article creation tool?
 
|[[File:Paizo_Publishing, LLC.png|16px]] [[User:Yoda8myhead|Yoda8myhead]] ([[User talk:Yoda8myhead|talk]]) 02:06, 10 March 2014 (UTC)}}
 
|[[File:Paizo_Publishing, LLC.png|16px]] [[User:Yoda8myhead|Yoda8myhead]] ([[User talk:Yoda8myhead|talk]]) 02:06, 10 March 2014 (UTC)}}
 +
{{Forum post
 +
| Looks like this is an issue with the [http://www.mediawiki.org/wiki/Extension_talk:DPLforum#Weird_Bug._Doubling_of_namespace_in_header CreateBox extension], which hasn't been updated recently. The InputBox extension seems to work fine. Fixing this should be as easy as editing [[Forum:Grand Lodge]] and [[Forum:Workshop]] and changing the <nowiki><createbox></nowiki> tags to <nowiki><inputbox></nowiki> and adding the {{xt|type{{=}}create}} parameter inside the tags, like so for Grand Lodge:
 +
 +
<pre><inputbox>
 +
type=create
 +
prefix=Forum:
 +
break=no
 +
preload=Template:Forumheader
 +
buttonlabel=Add a topic
 +
editintro=Template:Forum intro
 +
</inputbox></pre>
 +
 +
I think the only feature we lose is the automatic notification when creating a page using a title that already exists.
 +
 +
[[Forum:Grand Lodge]] and [[Forum:Workshop]] are protected, so an admin needs to make the changes.
 +
| [[User:Oznogon|Oznogon]] ([[User talk:Oznogon|talk]]) 02:05, 4 December 2014 (UTC) }}

Latest revision as of 02:05, 4 December 2014

Forums: Workshop > New forums have "Forum" twice in article names


I don't know when this problem started, but we now have to manually delete or move articles in the Forum namespace, as the automatic thread creation tool makes the titles "Forum:Forum:Thread title." Any way we can fix this behavior in the new article creation tool?
Looks like this is an issue with the CreateBox extension, which hasn't been updated recently. The InputBox extension seems to work fine. Fixing this should be as easy as editing Forum:Grand Lodge and Forum:Workshop and changing the <createbox> tags to <inputbox> and adding the type=create parameter inside the tags, like so for Grand Lodge:
<inputbox>
type=create
prefix=Forum:
break=no
preload=Template:Forumheader
buttonlabel=Add a topic
editintro=Template:Forum intro
</inputbox>

I think the only feature we lose is the automatic notification when creating a page using a title that already exists.

Forum:Grand Lodge and Forum:Workshop are protected, so an admin needs to make the changes.